Debian Edu Project
Summary
Roaming-workstation
Debian Edu networked roaming workstation packages

A metapackage containing dependencies for packages required on all networked workstation (thick client) installations in the Debian Edu Blend where the client might go offine once in a while.

Description

For a better overview of the project's availability as a Debian package, each head row has a color code according to this scheme:

If you discover a project which looks like a good candidate for Debian Edu to you, or if you have prepared an unofficial Debian package, please do not hesitate to send a description of that project to the Debian Edu mailing list

Links to other tasks

Debian Edu Roaming-workstation packages

Official Debian packages with high relevance

Education-desktop-other
Debian Edu non-GNOME- and non-KDE-specific desktop applications
Versions of package education-desktop-other
ReleaseVersionArchitectures
jessie1.812+deb8u1amd64,arm64,armel,armhf,i386,mips,mipsel,powerpc,ppc64el,s390x
wheezy1.713+deb7u1amd64,armel,armhf,i386,ia64,kfreebsd-amd64,kfreebsd-i386,mips,mipsel,powerpc,s390,s390x,sparc
sid1.928amd64,arm64,armel,armhf,hurd-i386,i386,kfreebsd-amd64,kfreebsd-i386,mips,mips64el,mipsel,powerpc,ppc64el,s390x
squeeze0.851amd64,armel,i386,ia64,kfreebsd-amd64,kfreebsd-i386,mips,mipsel,powerpc,s390,sparc
stretch1.924amd64,arm64,armel,armhf,i386,mips,mips64el,mipsel,ppc64el,s390x
buster1.928amd64,arm64,armel,armhf,i386,mips,mips64el,mipsel,ppc64el,s390x
Popcon: 0 users (0 upd.)*
Versions and Archs
License: DFSG free
Git

This metapackage depends on various office and desktop applications that are useful for teachers and their students.

This package also adds multi-language support to the system for the following languages:

  • ca (Catalan)
  • de (German)
  • el (Greek)
  • en (English, GB/US)
  • es (Spanish)
  • fr (French)
  • it (Italian)
  • nl (Dutch)
  • pt-br (Brazilian Portuguese)
  • sv (Swedish)
Education-networked-common
Debian Edu common networking packages
Versions of package education-networked-common
ReleaseVersionArchitectures
buster1.928amd64,arm64,armel,armhf,i386,mips,mips64el,mipsel,ppc64el,s390x
stretch1.924amd64,arm64,armel,armhf,i386,mips,mips64el,mipsel,ppc64el,s390x
sid1.928amd64,arm64,armel,armhf,hurd-i386,i386,kfreebsd-amd64,kfreebsd-i386,mips,mips64el,mipsel,powerpc,ppc64el,s390x
Popcon: 0 users (0 upd.)*
Versions and Archs
License: DFSG free
Git

A metapackage containing dependencies for packages required on all network installations (workstation, roaming workstation, minimal and main-server, but not standalone) in the Debian Edu Blend.

Gosa-desktop
Desktop integration for GOsa²
Versions of package gosa-desktop
ReleaseVersionArchitectures
jessie2.7.4+reloaded2-1+deb8u2all
wheezy-security2.7.4-4.3~deb7u3all
wheezy2.7.4-4.3~deb7u2all
squeeze2.6.11-3+squeeze2all
sid2.7.4+reloaded2-13all
buster2.7.4+reloaded2-13all
stretch2.7.4+reloaded2-13all
Popcon: 6 users (5 upd.)*
Versions and Archs
License: DFSG free
Git

This package includes a Gosa² menu definition for your desktop environment.

GOsa² is a combination of system-administrator and end-user web interface, designed to handle LDAP based setups.

Krb5-auth-dialog
tray applet for reauthenticating kerberos tickets
Maintainer: Guido Günther
Versions of package krb5-auth-dialog
ReleaseVersionArchitectures
sid3.20.0-3amd64,arm64,armel,armhf,i386,mips,mips64el,mipsel,powerpc,ppc64el,s390x
wheezy3.2.1-1+deb7u1amd64,armel,armhf,i386,ia64,mips,mipsel,powerpc,s390,s390x,sparc
squeeze0.16-4amd64,armel,i386,ia64,mips,mipsel,powerpc,s390,sparc
jessie3.12.0-2amd64,arm64,armel,armhf,i386,mips,mipsel,powerpc,ppc64el,s390x
stretch3.20.0-2amd64,arm64,armel,armhf,i386,mips,mips64el,mipsel,ppc64el,s390x
buster3.20.0-3amd64,arm64,armel,armhf,i386,mips,mips64el,mipsel,ppc64el,s390x
Debtags of package krb5-auth-dialog:
uitoolkitgtk
x11application
Popcon: 146 users (10 upd.)*
Versions and Archs
License: DFSG free
Git

krb5-auth-dialog is a simple tray applet that monitors kerberos tickets. It pops up reminders when the ticket is about to expire. Tickets can be refreshed at any time by clicking on the tray icon. It can also operate in "classic mode" as a simple dialog without any trayicon.

It features ticket autorenewal and supports pkinit.

Screenshots of package krb5-auth-dialog
Libnss-mdns
NSS module for Multicast DNS name resolution
Versions of package libnss-mdns
ReleaseVersionArchitectures
wheezy0.10-3.2amd64,armel,armhf,i386,ia64,kfreebsd-amd64,kfreebsd-i386,mips,mipsel,powerpc,s390,s390x,sparc
squeeze0.10-3.1amd64,armel,i386,ia64,kfreebsd-amd64,kfreebsd-i386,mips,mipsel,powerpc,s390,sparc
jessie0.10-6amd64,arm64,armel,armhf,i386,mips,mipsel,powerpc,ppc64el,s390x
stretch0.10-8amd64,arm64,armel,armhf,i386,mips,mips64el,mipsel,ppc64el,s390x
buster0.10-8amd64,arm64,armel,armhf,i386,mips,mips64el,mipsel,ppc64el,s390x
sid0.10-8amd64,arm64,armel,armhf,hurd-i386,i386,kfreebsd-amd64,kfreebsd-i386,mips,mips64el,mipsel,powerpc,ppc64el,s390x
Debtags of package libnss-mdns:
roleplugin
suitegnu
Popcon: 51 users (5 upd.)*
Versions and Archs
License: DFSG free
Git

nss-mdns is a plugin for the GNU Name Service Switch (NSS) functionality of the GNU C Library (glibc) providing host name resolution via Multicast DNS (using Zeroconf, aka Apple Bonjour / Apple Rendezvous ), effectively allowing name resolution by common Unix/Linux programs in the ad-hoc mDNS domain .local.

Libnss-sss
Nss library for the System Security Services Daemon
Versions of package libnss-sss
ReleaseVersionArchitectures
sid1.15.3-2amd64,arm64,armel,armhf,i386,mips,mips64el,mipsel,powerpc,ppc64el,s390x
jessie1.11.7-3amd64,arm64,armel,armhf,i386,mips,mipsel,powerpc,ppc64el,s390x
squeeze1.2.1-4+squeeze1amd64,armel,i386,ia64,mips,mipsel,powerpc,s390,sparc
stretch1.15.0-3amd64,arm64,armel,armhf,i386,mips,mips64el,mipsel,ppc64el,s390x
wheezy1.8.4-2amd64,armel,armhf,i386,ia64,mips,mipsel,powerpc,s390,s390x,sparc
buster1.15.3-1amd64,arm64,armel,armhf,i386,mips,mips64el,mipsel,ppc64el,s390x
Debtags of package libnss-sss:
roleshared-lib
Popcon: 163 users (8 upd.)*
Versions and Archs
License: DFSG free
Git

Provides a set of daemons to manage access to remote directories and authentication mechanisms. It provides an NSS and PAM interface toward the system and a pluggable backend system to connect to multiple different account sources. It is also the basis to provide client auditing and policy services for projects like FreeIPA.

This package provide the nss library to connect to the sssd daemon.

Libpam-mklocaluser
Configure PAM to create a local user if it do not exist already
Versions of package libpam-mklocaluser
ReleaseVersionArchitectures
wheezy0.8~deb7u1all
sid0.11all
buster0.11all
stretch0.11all
squeeze0.6all
jessie0.10all
Popcon: 69 users (1 upd.)*
Versions and Archs
License: DFSG free
Git

When the user log in for the first time, a local user is created in /etc/passwd and primary group created in /etc/group, and a local home directory is created in /home. This is useful on roaming computers when the password is set up to be cached by for example libpam-ccreds or sssd to allow login without network connectivity using the password provided by a network authentication service like Kerberos or LDAP.

Libpam-sss
Pam module for the System Security Services Daemon
Versions of package libpam-sss
ReleaseVersionArchitectures
jessie1.11.7-3amd64,arm64,armel,armhf,i386,mips,mipsel,powerpc,ppc64el,s390x
squeeze1.2.1-4+squeeze1amd64,armel,i386,ia64,mips,mipsel,powerpc,s390,sparc
stretch1.15.0-3amd64,arm64,armel,armhf,i386,mips,mips64el,mipsel,ppc64el,s390x
buster1.15.3-1amd64,arm64,armel,armhf,i386,mips,mips64el,mipsel,ppc64el,s390x
wheezy1.8.4-2amd64,armel,armhf,i386,ia64,mips,mipsel,powerpc,s390,s390x,sparc
sid1.15.3-2amd64,arm64,armel,armhf,i386,mips,mips64el,mipsel,powerpc,ppc64el,s390x
Debtags of package libpam-sss:
roleshared-lib
Popcon: 174 users (8 upd.)*
Versions and Archs
License: DFSG free
Git

Provides a set of daemons to manage access to remote directories and authentication mechanisms. It provides an NSS and PAM interface toward the system and a pluggable backend system to connect to multiple different account sources. It is also the basis to provide client auditing and policy services for projects like FreeIPA.

This package provide the pam module to connect to the sssd daemon.

Network-manager-gnome
network management framework (GNOME frontend)
Versions of package network-manager-gnome
ReleaseVersionArchitectures
wheezy0.9.4.1-5amd64,armel,armhf,i386,ia64,mips,mipsel,powerpc,s390,s390x,sparc
jessie0.9.10.0-2amd64,arm64,armel,armhf,i386,mips,mipsel,powerpc,ppc64el,s390x
stretch1.4.4-1amd64,arm64,armel,armhf,i386,mips,mips64el,mipsel,ppc64el,s390x
buster1.8.4-1amd64,arm64,armel,armhf,i386,mips,mips64el,mipsel,ppc64el,s390x
sid1.8.4-1amd64,arm64,armel,armhf,i386,mips,mips64el,mipsel,powerpc,ppc64el,s390x
squeeze0.8.1-2amd64,armel,i386,ia64,mips,mipsel,powerpc,s390,sparc
Debtags of package network-manager-gnome:
interfacedaemon, x11
networkconfiguration
roleprogram
suitegnome
uitoolkitgtk
useconfiguring
x11application
Popcon: 40006 users (15801 upd.)*
Versions and Archs
License: DFSG free
Git

NetworkManager is a system network service that manages your network devices and connections, attempting to keep active network connectivity when available. It manages ethernet, WiFi, mobile broadband (WWAN), and PPPoE devices, and provides VPN integration with a variety of different VPN services.

This package contains a systray applet for GNOME's notification area but it also works for other desktop environments which provide a systray like KDE or Xfce. It displays the available networks and allows users to easily switch between them. For encrypted networks it will prompt the user for the key/passphrase and it can optionally store them in the gnome-keyring.

Other screenshots of package network-manager-gnome
VersionURL
0.6.6-2https://screenshots.debian.net/screenshots/000/000/319/large.png
Screenshots of package network-manager-gnome

Official Debian packages with lower relevance

Cmst
QT GUI for Connman with system tray icon
Versions of package cmst
ReleaseVersionArchitectures
stretch2016.10.03-2amd64,arm64,armel,armhf,i386,mips,mips64el,mipsel,ppc64el,s390x
sid2017.09.19-1amd64,arm64,armel,armhf,i386,mips,mips64el,mipsel,powerpc,ppc64el,s390x
buster2017.09.19-1amd64,arm64,armel,armhf,i386,mips,mips64el,mipsel,ppc64el,s390x
Popcon: 55 users (53 upd.)*
Versions and Archs
License: DFSG free
Git

Graphical user interface to control the connman daemon. The connman daemon must be started as you normally would, this program just interfaces with that daemon. You can see what technologies and services connman has found, and for wifi services an agent is registered to assist in obtaining the information from you necessary to logon to the wifi service.

Screenshots of package cmst
Plasma-nm
Plasma5 networkmanager library.
Versions of package plasma-nm
ReleaseVersionArchitectures
jessie0.9.3.4-2amd64,arm64,armel,armhf,i386,mips,mipsel,powerpc,ppc64el,s390x
buster5.10.5-2amd64,arm64,armel,armhf,i386,mips,mips64el,mipsel,ppc64el,s390x
sid5.10.5-2amd64,arm64,armel,armhf,i386,mips,mips64el,mipsel,powerpc,ppc64el,s390x
stretch5.8.6-1amd64,arm64,armel,armhf,i386,mips,mips64el,mipsel,ppc64el,s390x
upstream5.11.1
Debtags of package plasma-nm:
uitoolkitqt
Popcon: 4819 users (4159 upd.)*
Newer upstream!
License: DFSG free
Git

Plasma desktop network manager.

This package is part of the KDE Plasma.

Wicd
wired and wireless network manager - metapackage
Versions of package wicd
ReleaseVersionArchitectures
buster1.7.4+tb2-4all
squeeze1.7.0+ds1-5+squeeze3all
wheezy1.7.2.4-4all
jessie1.7.2.4-4.1all
stretch1.7.4+tb2-4all
sid1.7.4+tb2-4all
Debtags of package wicd:
adminconfiguring, monitoring
networkconfiguration
rolemetapackage, program
scopeutility
usechecking, configuring, monitor
Popcon: 0 users (0 upd.)*
Versions and Archs
License: DFSG free
Git

Wicd is a general-purpose network configuration server which aims to provide a simple but flexible interface for connecting to networks. Its features include:

  • wide variety of settings;
  • ability to connect to (and maintain profiles for) both wired and wireless networks;
  • support for many encryption schemes, including WEP, WPA, WPA2 and custom schemes;
  • wireless-tools compatibility;
  • tray icon showing network activity and signal strength;
  • lack of GNOME dependencies (although it does require GTK+), making it easy to use in Xfce, Fluxbox, Openbox, Enlightenment, etc.

This is a metapackage, it allows installation of all the components of Wicd, including one of the clients, which must be manually chosen.

Screenshots of package wicd
*Popularitycontest results: number of people who use this package regularly (number of people who upgraded this package recently) out of 201342