Debian GIS Project
Summary
Bugs of task workstation
Total bugs: 61
Open bugs: 52
Fixed bugs: 9
Links to other tasks
Data 0 (0)
Development 100 (843)
Gps 103 (569)
Openstreetmap 50 (308)
Remote sensing 20 (53)
Statistics 0 (0)
Map server 3 (30)
Workstation 52 (275)
Legend
SeverityDependentSuggested
critical 0 0
grave 0 1
serious 0 0
important 1 5
normal 23 3
minor 3 0
wishlist 6 10

Summary bugs page of task Workstation

Immediately looking into bugs of the dependencies of this task is advised (275)*

Open bugs in dependent packages

1 important, 23 normal, 3 minor, 6 wishlist
703073 Wrong prototype of in avctest.c
990403 depends on deprecated qhull library upstream
279358 grace: Grace uses a dash, not a minus sign for negative numbers.
396363 FTBFS: Makefile:69: *** target pattern contains no `%'. Stop.
477093 grace: please implement an "Index" option for annotated value type upstream, wontfix
568393 Grace is not compiled with PDF support wontfix
599791 Confirmation dialog hidden behind print setup dialog
653251 grace: 180.0000 != 180.00000 != 180.000000 in data
743359 convert to freetype support help, upstream
379913 grass-doc: whatis parse errors in manpages upstream
716013 [Mayhem] Bug report on h5utils: h5tovtk crashes with exit status 139
638753 libhdf5-serial-1.8.7: threadsafe memory leaks moreinfo
715959 [Mayhem] Bug report on hdf5-tools: gif2h5 crashes with exit status 139
716008 [Mayhem] Bug report on hdf5-tools: h5copy crashes with exit status 139
716010 [Mayhem] Bug report on hdf5-tools: h5diff crashes with exit status 139
716011 [Mayhem] Bug report on hdf5-tools: h5dump crashes with exit status 139
716012 [Mayhem] Bug report on hdf5-tools: h5import crashes with exit status 139
740613 libhdf5-7: Please include support for compression with libaec
748587 Duplicate and conflicting definitions of variable FILENAME upstream
839784 libhdf5-dev: pkg-config file references ONLY the C library
915807 hdf5: CVE-2017-17507 security, upstream
958174 hdf5: please add the hdf5plugins
968559 libhdf5-openmpi-dev: hdf5-mpi.pc alternative sometimes goes missing moreinfo
177956 length greater than 1000000 fails upstream
796745 possibly build additional hdf4-tools-alt (without netcdf support)
917014 [libhdf4] Please provide Java package
953228 libmfhdfalt.so: should link with -ldfalt wontfix
583203 ogdi-dfsg: hard-codes tcl version in source
716225 [Mayhem] Bug report on ogdi-bin: ogdi_import crashes with exit status 139
751607 ogdi-dfsg: dyn_SelectLayer passes literal struct instead of pointer-to-struct
990394 depends on deprecated qhull library fixed-upstream, upstream
971698 Spatialite GUI and unicode upstream
974640 Spatialite GUI /CLI and shp upstream

Open bugs in suggested packages

1 grave, 5 important, 3 normal, 10 wishlist
378362 googleearth-package: Generated binary package has too many lintian warnings and errors help
406369 googleearth-package: Should produce .changes file help
439155 googleearth-package: Automatic run of make-googleearch-package on postinst
530394 sixty gcc missing messages
545243 no hashsum checks of downloaded content, thus allowing downloading and installation of malicious content
564419 googleearth-package generates bad dependencies on Debian unstable for amd64 architecture
604089 /usr/lib/googleearth/gpl.txt copylefts what files
617316 googleearth-package: crash
617420 googleearth-package: Please specify an Installed-Size field in the created googleearth package
651026 googleearth-package: Needs update for new Google Earth version
695298 Please strip files under /etc/cron* from the google earth tarball security
702757 Google Earth 7 is ready upstream!
720025 googleearth-package 1.0.0 always builds GE 6.x .deb
753693 googleearth-package: mention 'make-googleearth-package' in package description
765792 googleearth-package: googleearth package contains missing /usr/lib/googleearth/libcurl.so.4 md5sum
781215 google-earth-pro-is-now-free
881580 googleearth-package: Generated package is uninstallable, and application unrunnable
543162 [ncview] segfault when clicking on "Axes" button confirmed, upstream
989360 netcdf: Multiple security issues in ezxml security, upstream

Done bugs

993334 gdal: FTBFS: configure.ac: error: required file 'config.rpath' not found bookworm, ftbfs, sid, upstream
994003 grace: FTBFS with NetCDF 4.8.1 ftbfs
992810 grass: please migrate away from autoconf2.13 upstream
972537 please add --enable-ros3-vfd to the build options to allow RO access to HDF5 on S3
995594 libhdf5[-openmpi]-dev: missing Depends: libcurl-dev
984285 pdal: ftbfs with GCC-11 bookworm, ftbfs, sid, upstream
992813 postgis: please migrate away from autoconf2.13
994326 pyepr: Removal of the python3-*-dbg packages in sid/bookworm bookworm, sid
996793 python-shapely: please provide 1.8rc1 release in experimental
*To estimate the overall status of the packages in the dependencies of a metapackage a weighted severity is calculated. Done bugs are ignored and bugs in dependent and recommended packages are weighted by factor three compared to suggested packages. Release critical bugs have a much larger weight than important, while the contribution of normal bugs is even smaller and minor bugs have a very small weight. Wishlist bugs are ignored in this calculation. The resulting sum is compared to some boundaries to find a verbal form. The actual numbers need some adjustment to make real sense - this evaluation method is in testing phase.
The severities of bugs are weighted as follows:
critical10
grave10
serious10
important5
normal3
minor1
wishlist0
Last update: Thu, 21 Oct 2021 13:28:22 -0000