Debian Science Project
Summary
Bugs of task mathematics
Total bugs: 239
Open bugs: 221
Fixed bugs: 18
Links to other tasks
Biology 6 (111)
Chemistry 76 (780)
Data acquisition 62 (417)
Data management 40 (264)
Devices 13 (96)
Economics 23 (141)
Engineering 69 (696)
Engineering-dev 53 (477)
Geography 97 (628)
Geometry 7 (27)
Linguistics 26 (203)
Logic 35 (300)
Machine learning 39 (609)
Mathematics 221 (1774)
Mathematics-dev 170 (1555)
Meteorology 82 (436)
Meteorology-dev 179 (771)
Nanoscale physics 306 (2400)
Physics 84 (873)
Physics-dev 22 (232)
Presentation 80 (633)
Psychophysics 3 (33)
Robotics 97 (389)
Robotics-dev 20 (171)
Simulations 35 (379)
Social 0 (0)
Statistics 39 (327)
Tools 3 (18)
Typesetting 293 (2037)
Viewing 294 (1902)
Viewing-dev 42 (371)
Workflow 27 (172)
Legend
SeverityDependentSuggested
critical 0 0
grave 0 0
serious 4 0
important 39 2
normal 110 5
minor 18 0
wishlist 41 2

Summary bugs page of task Mathematics

Immediately looking into bugs of the dependencies of this task is advised (1774)*

Open bugs in dependent packages

4 serious, 39 important, 110 normal, 18 minor, 41 wishlist
915571 (no subject)
662581 man page for agda patch
736477 agda-mode: enable multiarch
902827 FTBFS: GHC OOM on armel/armhf ftbfs
992448 agda: fails to compile hello world
1003318 agda: Please package agda 2.6.2.1
986415 Updating the auto-07p Uploaders list
axiom (8) Homepage: Not maintained in Vcs Camm Maguire
231800 axiom: )edit command broken
349877 axiom: internal error while executing user function
407109 axiom: loops forever while )read'ing expression
716026 [Mayhem] Bug report on axiom-hypertex: htadd crashes with exit status 139
716335 [Mayhem] Bug report on axiom: sman crashes with exit status 139
716442 [Mayhem] Bug report on axiom-graphics: view2d crashes with exit status 139
827955 axiom: Uses too much memory to build
976754 axiom: missing homepage + new version
1001264 coinor-cbc is built with asserts enabled
715759 [Mayhem] Bug report on coinor-csdp: csdp-complement crashes with exit status 139
715760 [Mayhem] Bug report on coinor-csdp: csdp-graphtoprob crashes with exit status 139
715761 [Mayhem] Bug report on coinor-csdp: csdp-theta crashes with exit status 139
716368 [Mayhem] Bug report on coinor-libsymphony0: symphony crashes with exit status 139
773273 error when using SYMPHONY libraries in testing/unstable with clang
941172 /usr/bin/symphony: please compile symphony with USE_GLPMPL
582768 proofgeneral: file-error "cannot open load file" "hilit19"
605014 proofgeneral-coq: PG for coq unusable because hilit19 is missing
605024 coq: coq.el requires nonexistent hilit19
827861 Please add coq-8.5 to jessie-backports fixed-upstream, jessie, security, wontfix
979756 Please compute ABIs for Coq libraries
1003993 cryptominisat: reproducible-builds: BuildId differences triggered by RPATH patch
968118 dolfin: 64-bit tests fail
993516 dolfin: FTBFS with glibc 2.34
553670 freefem-examples: Non-working example
715915 [Mayhem] Bug report on freefem: freefem crashes with exit status 139
712526 freefem++: FreeFem++-mpi not working
715902 [Mayhem] Bug report on freefem++: ffbamg crashes with exit status 139
870054 freefem++: scalapack and blacs not found at build time
876467 freefem++: load of tetgen for 3d failed
884121 Build-Depends: libhypre-dev, but does not build against HYPRE
918919 freefem++: build does not detect PETSc
992924 freefem++: autopkgtest failure on arm64/ppc64el
686215 geogebra: exporting to asymptote complains "File unicodetex not found."
692728 New upstream release - 4.2.36
704771 geogebra: Impossible to export with an inequality
708543 geogebra: detect and avoid headless JREs
768150 geogebra: LC_MESSAGES should control the interface language, not LC_CTYPE
928739 geogebra: poor integration with KDE
976086 geogebra: Export to PDF is broken
357445 geomview: must it have dot-files in /usr/lib/geomview?
547500 geomview: segfaults when trying to create a PostScript snapshot of certain data
586597 geomview: PLOT3D grid file reader module: please include it patch
709307 geomview: Silently fail to start when running within xrdp/vnc (no 3D support)
1001124 geomview FTCBFS: AC_TRY_RUN check for popen fails patch, upstream
927140 getdp compiled without support for gmsh
950008 gfan: assertion fails on riscv64
582856 libginac-dev: Please build HTML docs
592675 ginac: please provide Debian packaging exposed at VCS
939326 [gmsh] Could you please restore MED support?
956454 gmsh: Seg fault doing almost anything related to radeonsi_dri.so
981128 libgmsh4: SIGABRT in dolfinx demo from gmsh polynomialBasis via Eigen::compute_inverse
292385 Segmentation fault in search_component() from libdotgen.so.0 fixed-upstream
336770 graphviz: fdp should have a m-limit
360970 Please build the graphviz-java plugins and language module
360977 Please build the graphviz-sharp plugins and language module
383261 Segmentation fault in dot_concentrate() from libgvplugin_dot_layout.so.2 fixed-upstream
388741 Font problem with Gdtclft (graphviz 2.8)
479674 graphviz-doc: Dot.ref.gz makes reference to ATT site - graphviz info moved to graphviz.org
514753 gv-ruby: Using engine nop globally sets -n, so neato is unusable afterwards
524408 graphviz: dot returns success even when interrupted
530310 graphviz: arrows get misdirected when nodes are one next to the other
539143 dotty.lefty: giving up on dot
540312 Dotty generated PS file are broken
557749 graphviz: different parallelograms have different angles
561212 graphviz: dotty crashes on attached file
574070 graphviz: Please add a 'dot -T help' option to cleanly list plugin renderer formats.
591089 graphviz: Bad arrow direction between same rank nodes fixed-upstream
594563 graphviz: core SVG output does not preserve alpha (transparency) color component
600710 graphviz: html table, fails on large COLSPAN values fixed-upstream
605993 corrupted PostScript output from neato
611129 graphviz: recommends ttf-liberation without explanation
617517 graphviz: Menus don't seem to work
620801 graphviz: Text on self-edges of a node is poorly placed
624355 [libgvc5-plugins-gtk] "gtk" lowercase in descriptions
626239 graphviz: fails to build with 'ld --no-copy-dt-needed-entries'
642643 graphviz-doc: Link to apparently defunct documentation
643332 [graphviz] tred removes empty labels
652952 gvpr: delete() causes processing to stop
674150 libgvc5 install fails unreproducible
688445 Can't select a font with Graphviz
697701 graphviz: dot: assertion failure in dot_position
698066 graphviz: dot crashes with *** glibc detected *** dot: malloc(): memory corruption: 0x097ca580 ***
700813 dot abort()s on valid input where neato, fdp, circo, twopi don't
712218 graphviz: gc - Please add -h option
724676 graphviz: build with parallel/concurrency (buildopts -j) fails
738470 graphviz: Patch to bootstrap without Gtk+, PHP, Ruby 1.8 patch
738847 graphviz: please include a binary to view dotfiles directly upstream
755124 Package size exploded patch
755127 unnecessary conflict with libgcv5
755525 graphviz: Upgrade pulls in unnecessary junk
779596 graphviz: style parameter sometimes causes edge to disappear upstream
815367 graphviz-doc: suggest doted in /usr/bin
820681 graphviz: please consider build-depend tightened on d-shlibs and drop local overrides
840105 graphviz: FTBFS on kfreebsd: conflicting declaration of strcasecmp()
841441 graphviz: Dies dumping memory map when specifying nodesep or minlen
845492 graphviz: Double free() for dot files with multiple digraphs
853468 graphviz: sfdp, gvmap are unusable without support for triangulation
870163 graphviz: VCS out of date
880112 graphviz: Nodes of SVG images do not get inserted if output is SVG
894589 graphviz: Segmentation fault in feasible_tree() at at ns.c:516 in libgvc.so.6
922201 libgraphviz-dev: dependencies pull in an almost complete desktop installation
925284 graphviz: CVE-2019-9904 fixed-upstream, security, upstream
926724 graphviz: CVE-2019-11023 fixed-upstream, security, upstream
944297 htmltable.c:1761: pos_html_tbl: assertion delx >= 0, when using nested fixedsize table
962021 graphviz: Embeds different date based on timezone patch
967456 graphviz: depends on deprecated GTK 2
980900 debian/watch doesn't find upstream releases patch
983886 libgvc6: fails foreign package installation patch
998256 graphviz: helping upgrade to 2.49.3
1003006 graphviz: please migrate Recommends fonts-liberation to fonts-liberation2
898514 hol-light: Loading verifier/m_verifier_main.hl from Formal_ineqs crashes with "Signal -7"
1002983 FTBFS with camlp5 8.00.02 bookworm, ftbfs, sid
916959 libjuliaX: please install files to /usr/lib/.../julia-${soversion}
953290 julia: PackageCompiler create_app requires root priveleges
963473 julia: LLVM error with CUDA.jl
974779 julia: Please upgrade to llvm-toolchain-11 bookworm, sid
976646 julia: FTBFS on armhf ftbfs
977193 julia REPL crashes on simple function
983547 julia-common: julia-config.jl does not find libjulia.so
1001604 Julia segmentation fault on Sid
1003433 julia: Outdated LTS version 1.5.x, current one is 1.6.5.
417695 liblpsolve55-dev: libs and includes should be harmonized
503314 liblpsolve55.so is in /usr/lib/lp_solve not /usr/lib wontfix
521076 lp-solve: crash when creating columns with C API
730124 doesn't include colamd functions, needs extra -lcolamd wontfix
731242 lp-solve: include xlis in lp-solve
875335 predictable /tmp file vulnerability while building lp-solve security
900905 lrslib FTCBFS: uses the build architecture compiler patch
382196 magnus has no .desktop patch
maxima (8) Homepage: Not maintained in Vcs Camm Maguire
431866 maxima: solve function cause infinite loop and infinite memory allocation
597531 maxima: fails to solve a simple 4th order equation upstream
597534 maxima: cannot solve the following integral upstream
779804 Please provide the ecl version of maxima patch
867999 maxima: does not reproducibly build
905316 maxima: printf hangs with format string, works in lisp mode
965154 maxima: insecure use of /tmp security, upstream
971905 maxima-src: please choose a mailing list provider where subscription is possible without loading nonfree javascript upstream
878693 please drop transitional package minisat2
900023 minisat2 should default to verbose build logs patch
700087 libmumps-dev: Please package the Scilab module
826960 mumps: Please package with metis and parmetis
961976 mumps: provide 64-bit build
989399 nauty: i386 baseline violation by using popcnt
991750 nauty: segfaults during sagemath testsuite
751344 netgen: please re-enable the linking with libav libraries
910247 python3-netgen: importing netgen.gui fails due to MPI_Comm_size()
924300 libnglib-6.2.1804: ldconfig does not find netgen shared object files
931082 netgen: Dead link in man 1 netgen
565216 octave: add support for loading HDF5 created outside Octave upstream, wontfix
598059 octave3.2: axis equal/square incorrect for gnuplot 4.4 upstream, wontfix
675509 octave: FLTK graphics backend not compatible with --no-line-editing option upstream, wontfix
741097 octave: nox package of Octave
783624 octave: Bad plotted data against time with long arrays confirmed, upstream
913638 Please, Depends: info-browser | info wontfix
921207 octave: gives wrong results when used with MKL
933300 liboctave-dev should not depend on a toolchain wontfix
954858 octave: GL warning 1.3 not suported
975902 octave-gui always shows "undecodable token: \001b(hex)[?2004h" in the prompt fixed-in-experimental, upstream
978029 octave: unable to load appropriate font
998842 octave: inv() causes segfault if io package pre-loaded
1000011 octave: depends on obsolete pcre3 library upstream
1000028 octave: depends on obsolete pcre3 library upstream
790327 openturns: FTBFS on mipsel "package requires more than 1GB RAM; do not build on mips/mipsel. Stop." ftbfs, patch, wontfix
948602 openturns-examples has a hard-coded dependency on python bookworm, bullseye, experimental, sid
1003818 openturns: X-Python3-Version: current is deprecated and must not be used
1001557 Ship html documentation
670339 proofgeneral: debian-pkg-add-load-path-item
746466 proofgeneral hijacks the emacs icon identity
779597 proofgeneral: "Buffer is read-only" when there is an error compiling dependant Coq files
917461 proofgeneral does not work in emacs-26
951567 proofgeneral: please, do not depend on emacs-gtk, proofgeneral works with emacs-lucid and even emacs-nox
984965 rheolef: /usr/bin/rheolef-config should be in package librheolef-dev, not rheolef
849150 sagemath: docbuild fails on arm64 and ppc64el ftbfs
920147 sagemath FTBFS on mipsel and mips64el ftbfs
983931 sagemath: ftbfs with -march=x86-64-v2
847394 Fails when LC_CTYPE is not explicitly UTF-8 upstream
681188 scilab: Issue with locales values and import/export text files l10n
712781 src:scilab: please use SLICOT Debian package instead of embedded copy help
747211 scilab: Allow scilab gui to start without opengl
896119 scilab: ATOMS system is broken in Scilab 6 on buster
903209 scilab: ATOMS system is broken in Scilab 6 on buster
959732 scilab: Scilab graphic window is empty when plotting
970490 scilab-cli: Incorrect version being displayed
982041 scilab: reduce Build-Depends
984799 scilab-full-bin for armhf and i386
988426 scilab,scilab-cli,scilab-test: metapackages uninstallable on 32-bit architectures
988527 scilab: unbound variable in /usr/share/bash-completion/completions/scilab
989364 scilab: Multiple security issues in ezxml security
990155 scilab-cli: legacy conffiles leftover
999966 scilab: depends on obsolete pcre3 library
506033 libscotchmetis-dev: Please add METIS_PartMesh* functions
653647 libscotchparmetis-dev: Please add ParMETIS_V3_Mesh2Dual
919308 scotch: do not use mpicc moreinfo, patch
961184 scotch: provide 64-bit build
1003079 scotch v7 MPI dgord dgpart tests fail
892622 singular: on mips64el, crashes 50% of the time when ASLR is enabled (the default)
973601 sympow: please make the build reproducible patch
710547 wxmaxima, maxima, gcl error(s) in relation to bug #593548
821353 wxmaxima: Alt+Up/Down does not work in Gnome 3
865740 wxmaxima: wxMaxima is caused segmentaion fault by ctrl+k moreinfo, unreproducible
881281 ugly scaled icons in the toolar patch
947002 wxmaxima version 19.07.0 onwards cannot display properly exponents
976082 wxmaxima: Keyword anchors jump to wrong position in help
983148 wxmaxima: reproducible builds: Embeds date in manpage dependent on timezone patch
975007 src:xmds2: autopkgtest times out on ppc64el (and sometimes on amd64)

Open bugs in suggested packages

2 important, 5 normal, 2 wishlist
602582 libann0: not usefull as *shared* library, because configuration at at compile-time is required upstream
930206 evolver FTCBFS: does not pass cross tools to make patch
655471 matlab-support: Missing dependency on libXpm4
702637 matlab-support: fails to install in clean chroot wontfix
702658 matlab-support: uninteruptable prompt on installation with readline
702832 matlab-support: source in main even though it depends on non-free matlab wontfix
713938 set MATLABPATH to point to system-wide location
891632 matlab-support: dpkg-preconfigure with DEBIAN_FRONTEND=noninteractive can hang because of endless loop
1002486 matlab-support: endless loop during interactive install

Done bugs

1003586 FTBFS with OCaml 4.13.1 ftbfs
997609 deap: FTBFS: error in deap setup command: use_2to3 is invalid. bookworm, fixed, ftbfs, sid
995424 libgmsh4: SONAME bump without package rename
1001770 libgmsh4.8: needs Breaks+Replaces: libgmsh4 (>= 4.8)
1004142 macaulay2-common: verify your package is compatible with libjs-katex 0.13
maxima (1) Homepage: Not maintained in Vcs Camm Maguire
979102 Legally problematic GPL-3+ readline dependency
995416 netgen: autopkgtest regression on armhf: Fatal Python error: Bus error ftbfs
998793 src:netgen: fails to migrate to testing for too long: autopkgtest failure bookworm, ftbfs, sid
990400 depends on deprecated qhull library
937214 openturns: Python2 removal in sid/bullseye bullseye, experimental, sid
966768 openturns: Unversioned Python removal in sid/bullseye bullseye, experimental, sid
984326 sagemath: ftbfs with GCC-11 bookworm, ftbfs, sid
986527 testsuite is too fragile - FTBFS randomly bookworm, bullseye, bullseye-ignore, ftbfs, patch, sid
992979 sagemath: Blank black page for 3D plots using three.js viewer
993149 sagemath FTBFS with eclib 20210625-1 bookworm, ftbfs, sid
998190 sagemath: package new upstream version bookworm, sid
1002587 python3-sage: Depends on unavailable package
1002849 python3-sage: missing Breaks+Replaces: sagemath-common (<< 9.4)
*To estimate the overall status of the packages in the dependencies of a metapackage a weighted severity is calculated. Done bugs are ignored and bugs in dependent and recommended packages are weighted by factor three compared to suggested packages. Release critical bugs have a much larger weight than important, while the contribution of normal bugs is even smaller and minor bugs have a very small weight. Wishlist bugs are ignored in this calculation. The resulting sum is compared to some boundaries to find a verbal form. The actual numbers need some adjustment to make real sense - this evaluation method is in testing phase.
The severities of bugs are weighted as follows:
critical10
grave10
serious10
important5
normal3
minor1
wishlist0
Last update: Thu, 27 Jan 2022 22:23:54 -0000