Debian Science Project
Summary
Bugs of task numericalcomputation
Total bugs: 161
Open bugs: 137
Fixed bugs: 24
Links to other tasks
Biology 6 (111)
Chemistry 76 (780)
Data acquisition 62 (417)
Data management 40 (264)
Devices 13 (96)
Economics 23 (141)
Engineering 69 (696)
Engineering-dev 53 (477)
Geography 97 (628)
Geometry 7 (27)
Linguistics 26 (203)
Logic 35 (300)
Machine learning 39 (609)
Mathematics 221 (1774)
Mathematics-dev 170 (1555)
Meteorology 82 (436)
Meteorology-dev 179 (771)
Nanoscale physics 306 (2400)
Physics 84 (873)
Physics-dev 22 (232)
Presentation 80 (633)
Psychophysics 3 (33)
Robotics 97 (389)
Robotics-dev 20 (171)
Simulations 35 (379)
Social 0 (0)
Statistics 39 (327)
Tools 3 (18)
Typesetting 293 (2037)
Viewing 294 (1902)
Viewing-dev 42 (371)
Workflow 27 (172)
Legend
SeverityDependentSuggested
critical 0 0
grave 0 1
serious 7 0
important 29 2
normal 65 8
minor 4 0
wishlist 19 2

Summary bugs page of task Numerical computation

Immediately looking into bugs of the dependencies of this task is advised (1286)*

Open bugs in dependent packages

7 serious, 29 important, 65 normal, 4 minor, 19 wishlist
838908 src:arrayfire: New upstream release (3.4.0)
892288 arrayfire FTBFS on i386: test segfaults bookworm, bullseye, buster, fixed-upstream, ftbfs, patch, sid
897707 arrayfire: ftbfs with GCC-8 bookworm, bullseye, buster, patch, sid
959695 calculix-cgx: freeglut (cgx): Menu manipulation not allowed while menus in use.
877316 clblas: Crashes on single-precision-only hardware, due to double-precision literals patch, upstream
891073 clblas: please make the build reproducible patch
921611 clblas: crashes (not just fails) on compile failure patch
921890 clblas: error: variables in the local address space can only be declared in the outermost scope of a kernel function patch, upstream
942963 clblas: Python2 removal in sid/bullseye bookworm, bullseye, sid
949767 clblas: *gemm wrong answers in out-of-order queues bookworm, bullseye, sid
1003375 clfft: reproducible-builds: BuildId differences triggered by RPATH patch
1001264 coinor-cbc is built with asserts enabled
716368 [Mayhem] Bug report on coinor-libsymphony0: symphony crashes with exit status 139
773273 error when using SYMPHONY libraries in testing/unstable with clang
941172 /usr/bin/symphony: please compile symphony with USE_GLPMPL
965214 dune-grid: please lower parallel builds patch
856677 esys-particle: incorrect _form0.ps file is the cause of documentation indexing failure
901849 esys-particle disables the tests on some archs for the build, but not for the autopkg tests
946206 esys-particle: autopkgtest times out when module import fails
753618 wishlist: gnudatalanguage-nox package
877294 gnudatalanguage: gdl segfaults while running testsuite upstream
976912 coyote: FTBFS on ppc64el (arch:all-only src pkg): Magick: abort due to signal 6 (SIGABRT) "Abort"... bullseye, ftbfs, sid
1002584 gnudatalanguage: small test_tic_toc tolerance patch, pending
1002788 gnudatalanguage: autopkgtest failure with PROJ 8.2.1
955775 ipython3: entry_points not working with virtualenvwrapper
916959 libjuliaX: please install files to /usr/lib/.../julia-${soversion}
953290 julia: PackageCompiler create_app requires root priveleges
963473 julia: LLVM error with CUDA.jl
974779 julia: Please upgrade to llvm-toolchain-11 bookworm, sid
976646 julia: FTBFS on armhf ftbfs
977193 julia REPL crashes on simple function
983547 julia-common: julia-config.jl does not find libjulia.so
1001604 Julia segmentation fault on Sid
1003433 julia: Outdated LTS version 1.5.x, current one is 1.6.5.
975488 lammps FTBFS: error: format not a string literal and no format arguments ftbfs
988849 lammps-doc: broken symlink: /usr/share/doc/lammps/html/index.html -> Manual.html
377271 duplicate copy of agg shipped and used
604402 python-matplotlib-data: includes local copies of fonts
796905 python3-matplotlib: Matplotlib startup feels extremely slow
797918 python3-matplotlib: Matplotlib startup feels extremely slow
803411 MathTextParser('Agg') causes a ZeroDivisionError on s390x
977469 matplotlib: Please make package bootstrappable
994079 python3-matplotlib: TkAgg backend emits errors on savefig() with tight option
855241 libmetis-dev: missing libmetis.a
961183 metis: providing a 64-bit build
524073 python-numpy: please split atlas support into an optional package
827168 numpy: Please make numpy.i 'visible'
877754 NaN -> datetime = 0 (not NaT) on arm*
943369 numpy: test failures do not fail build wontfix
945824 [python3-numpy] Depends on python3.8 and python3.7 wontfix
946189 python-numpy: blas -> blis
965031 python3-numpy: please clarify the license for some files in debian/copyright
972551 inclusion of Python3.9 breaks compatibility with libpython3-dev
975546 Please, support multiple flavor of numpy for different use cases.
998084 python3-numpy adds unnecessary link `/usr/include/python3.9/numpy` moreinfo
1003233 numpy: Please move the BD needed to build the -doc package to Build-Depends-Indep moreinfo, patch
1003805 python3-numpy: depends on two different Python versions wontfix
565216 octave: add support for loading HDF5 created outside Octave upstream, wontfix
598059 octave3.2: axis equal/square incorrect for gnuplot 4.4 upstream, wontfix
675509 octave: FLTK graphics backend not compatible with --no-line-editing option upstream, wontfix
741097 octave: nox package of Octave
783624 octave: Bad plotted data against time with long arrays confirmed, upstream
913638 Please, Depends: info-browser | info wontfix
921207 octave: gives wrong results when used with MKL
933300 liboctave-dev should not depend on a toolchain wontfix
954858 octave: GL warning 1.3 not suported
975902 octave-gui always shows "undecodable token: \001b(hex)[?2004h" in the prompt fixed-in-experimental, upstream
978029 octave: unable to load appropriate font
998842 octave: inv() causes segfault if io package pre-loaded
1000011 octave: depends on obsolete pcre3 library upstream
1000028 octave: depends on obsolete pcre3 library upstream
611959 non-free documentation in the package?
839913 src:python-arrayfire: new upstream release
886421 python-escript: FTBFS on m68k: hwloc_set_cpubind returned "Error" for bitmap "0" upstream
1002428 python-escript: FTBFS: RuntimeError: Unknown key (ASFLAGS) in dpkg-buildflags: bookworm, ftbfs, sid
974562 kodi: Extended info for actor, only works the first time moreinfo, upstream
988424 python-sparse: failure in tests fixed-upstream, ftbfs
1002402 python-sparse: FTBFS: dh_auto_test: error: pybuild --test --test-pytest -i python{version} -p "3.10 3.9" returned exit code 13 bookworm, ftbfs, sid
955015 python3-xarray: Backend api engine grib broken
702354 Useless (and possibly undefined) conversion from double to enum
710289 r-base-core: Partial upgrades from wheezy to jessie are broken
752609 r-base-dev: Please provide a method to run upstream unit tests at package build time
812544 r-base: FTBFS in a clean sid pbuilder enviromwent
861636 FTBFS when sources imported into git
862112 r-base-dev: Generate reproducible output independently of the build path patch, upstream
888399 r-base-core: [m68k] bogus "missing value where TRUE/FALSE needed" errors upstream
916773 r-base: CRAN packages fail to install.
928653 r-base: change R_LIBS_USER default location
982465 r-base: dyn.load not useful for system libraries
681188 scilab: Issue with locales values and import/export text files l10n
712781 src:scilab: please use SLICOT Debian package instead of embedded copy help
747211 scilab: Allow scilab gui to start without opengl
896119 scilab: ATOMS system is broken in Scilab 6 on buster
903209 scilab: ATOMS system is broken in Scilab 6 on buster
959732 scilab: Scilab graphic window is empty when plotting
970490 scilab-cli: Incorrect version being displayed
982041 scilab: reduce Build-Depends
984799 scilab-full-bin for armhf and i386
988426 scilab,scilab-cli,scilab-test: metapackages uninstallable on 32-bit architectures
988527 scilab: unbound variable in /usr/share/bash-completion/completions/scilab
989364 scilab: Multiple security issues in ezxml security
990155 scilab-cli: legacy conffiles leftover
999966 scilab: depends on obsolete pcre3 library
991753 python3-scipy: build with pythran support
1003417 scipy: build ignores test failures
1003880 libblis3-openmp: i386 triggers segfault in scipy arpack test (test_hermitian_modes)
1004197 scipy: FTBFS on hppa - insufficent long double support
1001484 sfepy: (autopkgtest) needs update for python3.10: Sequence' from 'collections' is removed bookworm, sid
951051 spyder3: Inserting a breakpoint in multi-file project using the spyder GUI
989660 spyder: When autoformat-on-save is on, the code is duplicated in the code editor
960766 suitesparse: build docs arch-indep only
989550 suitesparse: enhance 64-bit support in suitesparse
876300 libsundials-dev: libsundials-serial-dev is gone
892910 please provide shared libraries for Fortran interfaces
950574 sundials: Should ship pkgconfig files
997664 sundials: apparent ABI bumps in sundials5 library packages
998184 libsundials-sunlinsol2: dependency on certain flavor of libsundials-nvecparallel
898126 theano: memory leak
1001030 theano: build-depends on uglifyjs.terser which is going away
985699 xtensor: tests fail on less common architectures
994246 xtensor: arm64 FTBFS: xsimd neon error xsimd::batch_bool does not have any field named ‘simd_complex_batch_bool’
994248 xtensor: build error on i686 with xsimd: incomplete type xsimd::batch<long int, 8>
580524 SIGFPE not catchable on MIPS without an FPU wontfix
918711 yorick-full makes all yorick RC buggy too easily

Open bugs in suggested packages

1 grave, 2 important, 8 normal, 2 wishlist
982963 bcolz: drop unused python3-cpuinfo build dependency patch
1001660 bcolz: autopkgtest python3-bcolz fails to run any tests patch
1000376 calculix-ccx-doc: wrong version of calculix documentation (not updated to v2.17?). newcomer
930206 evolver FTCBFS: does not pass cross tools to make patch
655471 matlab-support: Missing dependency on libXpm4
702637 matlab-support: fails to install in clean chroot wontfix
702658 matlab-support: uninteruptable prompt on installation with readline
702832 matlab-support: source in main even though it depends on non-free matlab wontfix
713938 set MATLABPATH to point to system-wide location
891632 matlab-support: dpkg-preconfigure with DEBIAN_FRONTEND=noninteractive can hang because of endless loop
1002486 matlab-support: endless loop during interactive install
792036 [libmetis-edf-dev] missing metis.h
982647 spyder-reports: incompatible with spyder 4.2.1+ ftbfs

Done bugs

997197 clfft: FTBFS: generator.transpose.cpp:1092:95: error: taking address of rvalue [-fpermissive] bookworm, ftbfs, patch, sid
1002094 compyle: FTBFS: dh_auto_test: error: pybuild --test --test-pytest -i python{version} -p "3.10 3.9" returned exit code 13 bookworm, ftbfs, sid
997609 deap: FTBFS: error in deap setup command: use_2to3 is invalid. bookworm, fixed, ftbfs, sid
1004122 ipython: CVE-2022-21699 security, upstream
985559 python-matplotlib-data should depend on dejavu fonts instead of bitstream vera
987629 python3-matplotlib: Please do not suggest transitional dummy package ttf-staypuft
990339 matplotlib: reproducible builds: embeds current year in documentation fixed-upstream, patch
994533 python3-matplotlib: Fails to import under Wayland fixed-upstream, upstream
996717 python-matplotlib-data: please Depends on fonts-dejavu | ttf-bitstream-vera
1000435 Matplotlib crashes on mips64el in lines.py ftbfs
1000774 python3-matplotlib: Segfault on mips64el in draw ftbfs
1001318 python-matplotlib-data: missing copyright file
1002923 python3-matplotlib: Plotting with usetex results in 'Script file /usr/share/matplotlib/mpl-data/kpsewhich.lua not found'
1000678 python-numpy-doc: numpy.i is shipped as documentation, even though it is a header
1001518 python-numpy-doc: Missing fonts
990400 depends on deprecated qhull library
997029 pysph: FTBFS in testing and unstable ftbfs
999530 python-escript: FTBFS with numpy 1.21 (in experimental): ImportError: cannot import name 'griddata' from 'matplotlib.mlab' (/usr/lib/python3/dist-packages/matplotlib/mlab.py) bookworm, ftbfs, sid
993781 missing Depends: python3-jinja2: xarray uses dask widgets
991752 python-scipy-doc: build docs with sphinx-panels
1002065 scipy build-depenencies unsatisfiable in testing/unstable bookworm, ftbfs, sid
1002144 scipy: FTBFS: unsatisfiable build-dependency: python3-pybind11 (< 2.8) but 2.8.1-3 is to be installed bookworm, ftbfs, sid
1003282 python-scipy-doc: Missing fonts
993107 theano: autopkgtest depends on libclblas-dev which is not in testing *and* has skip-not-installable
*To estimate the overall status of the packages in the dependencies of a metapackage a weighted severity is calculated. Done bugs are ignored and bugs in dependent and recommended packages are weighted by factor three compared to suggested packages. Release critical bugs have a much larger weight than important, while the contribution of normal bugs is even smaller and minor bugs have a very small weight. Wishlist bugs are ignored in this calculation. The resulting sum is compared to some boundaries to find a verbal form. The actual numbers need some adjustment to make real sense - this evaluation method is in testing phase.
The severities of bugs are weighted as follows:
critical10
grave10
serious10
important5
normal3
minor1
wishlist0
Last update: Thu, 27 Jan 2022 22:23:54 -0000